Rgbstock forum

forum > Technical questions > Uploading glitch

Uploading glitch

1. ColinBrough23 December 2013, 15:35 GMT +01:00

Tried to upload three related images. Flash uploader, seemed to upload the three files OK, but then when I got to filling in the keywords etc noticed that it had "duplicated" one of the images? Images were:


Image one had the right thumbnail. Image two and three had the same thumbnail as each other, that from image three. If I fill in keywords and then submit for approval, the two "duplicates" end up in "Your Photo management" with the same image id (eg oqQYB0m).

I deleted the duplicated ones (not being sure which one was the "real" one!); when I deleted one the other appeared with a grey/thumbnail being generated space...

One screengrab is here:


2. ColinBrough23 December 2013, 15:38 GMT +01:00

As an addendum, I've just re-tried and got a repeat behaviour - I've left the two "duplicates" in the Photo Management so reviewers/developers can see them...

Another screengrab:


3. ColinBrough23 December 2013, 18:17 GMT +01:00

(And now those two have been rejected as too similar!)

4. jazza23 December 2013, 19:42 GMT +01:00

That is really odd behavior. I can see the images(name, keywords, upload time and so on) in the database and they look exactly the same.

We will investigate a little more. Please do not delete this photos for this moment.

Can you please try to upload with a different browser? What happens then?

5. ColinBrough24 December 2013, 12:35 GMT +01:00

Thanks Jazza. Tried a re-upload again this morning, and it worked OK - they are now waiting approval... Afraid I went on "auto-pilot" and deleted the duplicate ones, then realised I shouldn't have - sorry!

(Don't have easy access to another browser on this machine, so couldn't try that.)

Will report again if I have a repeat...

6. jazza24 December 2013, 12:41 GMT +01:00

No problem Collin. I made a small fix to prevent double names. I am not sure if it helps because this issue is difficult to reproduce, but I think it is ok now.

7. ColinBrough9 January 2014, 16:32 GMT +01:00

Jazza, just had another instance of this - there are two copies of a "Scarborough headland image" in my photo management pages, which I will leave for you to look at (irrespective of whether they get rejected meantime for being too similar!!).

The original filenames that I uploaded were ScarboroughHeadland01.jpg and ...02.jpg

Do they get immediately named by the server as they are uploaded, or is something of the original name reused - are my filenames too long, or something?

Initial suspicion that it had gone wrong came on the upload page - had uploaded just those two images, and one had a thumbnail while the other didn't - stuck saying "generating thumbnail". Entered keywords etc, then "copy values" to fill in for the second image, then shows up with the same filename (ossFsSc) twice over in photomanagement...

Sorry if I'm being too verbose - just trying to capture as much information for the bug report as possible!!

8. ColinBrough9 January 2014, 16:54 GMT +01:00

Umm, now they/the duplicate/whatever is actually in the database have been approved for publication. Wonder what will happen when they go live....!

9. ColinBrough9 January 2014, 17:56 GMT +01:00

Intriguing! One has appeared in my gallery, but the other appears "stuck" (?) in my photo-management - approved, but not published... (Let me know if you need anything else, like the original uploaded files somewhere accessible or something.)

10. jazza10 January 2014, 8:47 GMT +01:00

We have to investigate this problem. Can't say what is going wrong at the moment.

11. lennie10 January 2014, 13:00 GMT +01:00

After investigating it, my conclusion is: concurrent programming is hard. I remember Twitter created a whole new piece of software to solve that problem for them. :-)

Jay's fix from last time wouldn't have helped.

We are thinking about a new solution.

12. ColinBrough10 January 2014, 13:16 GMT +01:00

Concurrent programming is Indeed hard - in a previous life I was on a developer at www.epcc.ed.ac.uk, programming for a variety of academic and indistrial clients who wanted to use parallel/concurrent programming for performance reasons. Its not what I do for a living now, and I'm about to be out of the country for a few weeks, but happy to try and help if I can - and not just with annoying bug reports!!

13. lennie10 January 2014, 13:35 GMT +01:00

In this context hard is just: easy to get wrong.

Nothing really serious. :-)

Jay or I, after we've properly discussed the possible solutions later today, will create a fix later.

The import bit is, we know where the problem is and have possible solutions.

14. jazza10 January 2014, 22:55 GMT +01:00

People like you helps us Colin lot. It is not annoying at all and we fixed the problem now.

15. ColinBrough14 January 2014, 19:06 GMT +01:00

I notice that the duplicate has now disappeared from my photo management page. Can I now re-upload the image it was meant to be?

16. jazza14 January 2014, 21:48 GMT +01:00

I deleted the duplicate, It was me. You can re upload the photo now, Colin

17. ColinBrough11 January 2016, 16:43 GMT +01:00

This may be a new issue, rather than a reappearance of this one, so this maybe should be a new thread - but connecting it to this history seemed like it might be helpful....

Uploaded four images in a set last night ("Craigowl Landscape"). All were approved. Three of them are now in my Gallery, and there is an image in my Photo Management that says "approved, waiting for publication". Its been there all day... Even more puzzling, it appears to be a repeat of one of the images approved (http://www.rgbstock.com/photo/pztzdsW/Craigowl+Landscape), and another of the images I submitted is "missing" (I've put a lower resolution version of the missing image here in case it helps visually identify it: http://www.colinbrough.pwp.blueyonder.co.uk/CraigowlLandscape02.jpg )

Feels like some kind of corruption of the internal database, but not sure what is going on...

18. xymonau11 January 2016, 17:59 GMT +01:00

I'll see if Jay can fix it, Colin.

19. jazza11 January 2016, 21:42 GMT +01:00

I have to look into this problem. No photos in the queue right now.

20. ColinBrough11 January 2016, 22:01 GMT +01:00

Thanks. Here's a screengrab of what I currently see in my Photo Management:


And in my Gallery - see how the same image seems to appear here also, but the one I mention above is missing...


21. jazza13 January 2016, 8:53 GMT +01:00

I understand what the problem is. Both photos have the same name. The photo-file names on the server needs to be unique. In this case they are not unique. Colin: you can delete the photo that is 'waiting', and upload it again.
I will examine the problem and will try to solve it.

22. ColinBrough13 January 2016, 11:50 GMT +01:00

Jay, thanks. When I went to delete it, I went to photo management. First stab at deleting didn't seem to work. Tried again, long pause, deleted it - but also deleted the duplicate file name image (already approved) from my gallery... I will re-upload both the previously approved image and the one that somehow got lost/mangled on the way through and see what happens this time! Thanks for looking into this...

23. jazza13 January 2016, 12:01 GMT +01:00

Sorry for the convenience Collin. This issue needs a bugfix soon. I will post in this thread again when it is solved.

24. jazza20 January 2016, 11:37 GMT +01:00

The problem is solved.

Please sign in or sign up if you want to participate in the forum discussions.

Lightbox . FAQ . contact . license agreement . terms of use . about . www.hqstock.com free stock photos totally free stock photos stock photos high quality free stock photos totally free stock photos totally free stock photos totally free stock images free stock images Christmas competition 2015 editors' pick alternative to sxc.hu Rgbstock blog and news
| English | Deutsch | Español | Polski | Português | Nederlands |
Shutterstock is official partner of Rgbstock